$re = '/^(?:0?1|601)/m';
$str = '123456789
0123456789
60123456789
+60123...';
$subst = "+601";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;