import Foundation
let pattern = #"CREATE +?(TEMPORARY +)?TABLE *(?P<db>.*?\.)?(?P<table>.*?)\((?P<col>.*?)\).*?USING +([^\s]+) *(PARTITIONED BY \((?P<pcol>.*?)\))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
CREATE TEMPORARY TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet PARTITIONED BY (DATA2, DATA3)
CREATE TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)