import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?!\\s)\\D";
final String string = "\\d+(?!\\W)\\D\n"
+ ".\\d+(?!\\s)\\D\n"
+ "[0-9]+[a-zA-Z]+|[a-zA-Z]+[0-9]+\n"
+ "[0-9]+[a-zA-Z]\n\n"
+ "25 - not this number\n\n"
+ "the cow just over the moon and the sun is in 1the sky\n\n"
+ "26 - not this number\n\n"
+ "5one day is soon and soon is near take 5529care, 30over and out\n\n"
+ "59 - not this number\n\n"
+ "The covers at near the back of the 59closet, and when found have them place on the each of the beds. However you see the pillow cases use the ones on the 9second shelve.\n\n"
+ "60 not this number\n\n"
+ "The hand sanitizer 30was actually clear glue.\n\n"
+ "61 not this number\n\n"
+ "I only enjoy window 16shopping when the 4windows are transparent.\n\n"
+ "62 not this number\n\n"
+ "The Great Dane looked more like a horse than 2a dog.\n\n"
+ "63 not this number\n\n"
+ "If you spin around three times, you'll start 150to feel melancholy.\n\n"
+ "160 not this number\n\n"
+ "When 8I was little I had a car door slammed shut on my 7hand and I still remember it quite 72vividly.\n\n"
+ "172 not this number\n\n"
+ "I would have gotten the promotion, but my attendance wasn’t good enough 17for movement.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}