# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/String\.format\((\".*\")?\, ?(.*)\);/$1.formatted\($2\);/gm;t' <<< "String.format(\"%s foo %s bar\", bar(), foo());"