using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ประเทศ)|(อเมริกา|เกาหลีใต้|เกาหลีเหนือ|ฝรั่งเศส|อิตาลี)|ประเทศ.*";
string input = @"ประเทศอเมริกาเป็นประเทศที่ดี
ประเทศเกาหลีใต้เป็นประเทศที่ดี
เกาหลีใต้คือประเทศ
ประเทศเกาหลีเหนือคือประเทศสวยงาม
ประเทศญี่ปุ่น
ประเทศอเมรกาเป็นประเทศที่ดี
เมืองที่สวยงามคือประเทศที่ดีงามอย่างฝรั่งเศสแต่ก็ไม่ได้มากไปกว่าอิตาลีที่เป็นประเทศประเทศหนึ่งเหมือนกัน
ประเทศรักสงบ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}