import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ประเทศ)|(อเมริกา|เกาหลีใต้|เกาหลีเหนือ|ฝรั่งเศส|อิตาลี)|ประเทศ.*";
final String string = "ประเทศอเมริกาเป็นประเทศที่ดี\n"
+ "ประเทศเกาหลีใต้เป็นประเทศที่ดี\n"
+ "เกาหลีใต้คือประเทศ\n"
+ "ประเทศเกาหลีเหนือคือประเทศสวยงาม\n"
+ "ประเทศญี่ปุ่น\n"
+ "ประเทศอเมรกาเป็นประเทศที่ดี\n"
+ "เมืองที่สวยงามคือประเทศที่ดีงามอย่างฝรั่งเศสแต่ก็ไม่ได้มากไปกว่าอิตาลีที่เป็นประเทศประเทศหนึ่งเหมือนกัน\n"
+ "ประเทศรักสงบ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}