import re
regex = re.compile(r"(ประเทศ)|(อเมริกา|เกาหลีใต้|เกาหลีเหนือ|ฝรั่งเศส|อิตาลี)|ประเทศ.*", flags=re.MULTILINE)
test_str = ("ประเทศอเมริกาเป็นประเทศที่ดี\n"
"ประเทศเกาหลีใต้เป็นประเทศที่ดี\n"
"เกาหลีใต้คือประเทศ\n"
"ประเทศเกาหลีเหนือคือประเทศสวยงาม\n"
"ประเทศญี่ปุ่น\n"
"ประเทศอเมรกาเป็นประเทศที่ดี\n"
"เมืองที่สวยงามคือประเทศที่ดีงามอย่างฝรั่งเศสแต่ก็ไม่ได้มากไปกว่าอิตาลีที่เป็นประเทศประเทศหนึ่งเหมือนกัน\n"
"ประเทศรักสงบ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")