import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bint\\s+(?:(?:[A-Z](?:[a-z](?![a-z])|[0-9](?![0-9])|_(?!__))+)(?:,\\s*|\\s*;)){1,5}(?<=;)|\\b(?:bool|double)\\s+(?:(?:[A-Z](?:[a-z0-9]+|_(?!__))+)(?:,\\s*|\\s*;)){1,5}(?<=;)";
final String string = "Valid:\n\n"
+ "int Xy;\n"
+ "double A1b, B_2;\n"
+ "bool Cx, D3_z;\n\n"
+ "Invalid:\n\n"
+ "int X;\n"
+ "int X___y;\n"
+ "int XY;\n"
+ "int X11;\n"
+ "double 1A;\n"
+ "int Xy, A1b, B_2, C3_d, D4e, E5f;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}