#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<idval>\b[A-F\d]{40}\b)(.|\n)*?(?P<ip>\b((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\b).?(?P<date>\b\d{4}(-\d{2}){2} (\d{2}:){2}\d{2}\b)"
Local $sString = "" & @CRLF & _
"IDVal 4273E6D162ED2717A1CF4207A254004CD3F5307B" & @CRLF & _
"Posted 2022-12-28 07:35:55" & @CRLF & _
"Status 2022-12-28 08:10:11" & @CRLF & _
"Entry 21.12.26.23 2022-12-28 13:10:30" & @CRLF & _
"Entry 113.132.26.203 2022-12-28 12:56:30" & @CRLF & _
"Entry 31.12.27.22 2022-12-28 12:35:30" & @CRLF & _
"IDVal 0D12D8E72DED99EE31BB0C57789352BED0CEEEFF" & @CRLF & _
"Posted 2022-12-28 07:30:55" & @CRLF & _
"Status 2022-12-28 06:10:11" & @CRLF & _
"Entry 51.102.52.36 2022-12-28 07:10:30" & @CRLF & _
"IDVal D947623B30C9D6E142E7D90FC7368B1A2A4F5045" & @CRLF & _
"Posted 2010-12-27 04:35:55" & @CRLF & _
"Status 2010-12-26 03:10:11" & @CRLF & _
"Entry 11.12.147.2 2022-12-28 07:20:30" & @CRLF & _
"Entry 91.177.62.236 2022-12-27 07:10:30" & @CRLF & _
"Entry 78.102.152.89 2022-12-25 07:10:30"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")