package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0[1-9]|[12][0-9]|3[01])[\/](0[1-9]|1[012])[\/]\d{4}$`)
var str = `12/12/2022`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}