re = /^(0[1-9]|[12][0-9]|3[01])[\/](0[1-9]|1[012])[\/]\d{4}$/m
str = '12/12/2022'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end