using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^[:alpha:]\n]*[[:alpha:]])(?=[[:alpha:]]*[^[:alpha:]\n])\S*$";
string input = @"AWfrer546
ASdew34254%$
AS dew 342 54%$
EQWRERrewr
rrerer";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}