import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[a-z\\s]+id=[\\'\\\"]mobile[\\w]+[\\'\\\"][\\sa-zA-Z\\d\\'\\=\\;\\:]*>([a-zA-Z\\d\\s]+)<[\\/a-z\\s]+>";
final String string = "<div id='mobileBody'>Message</div>\n"
+ "<div id=\"mobiletitle\" >Message</div>\n"
+ "<div id='mobileBody' style='display:none;'>Message</div>\n"
+ "<div id='mobileTitle' style='display:none;'>Message</div>\n"
+ "<div id=\"title\" >asd</div>\n"
+ "<div id=\"title\">asd</div>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}