$re = '/profile\d+\.name=(.+)/m';
$str = 'profile2.name=share2
profile8.name=share8
profile4.name=shareSSH
profile9.name=share9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);