package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*(?|(dog).*(cat)|(cat).*(dog)).*`)
var str = `aasdfadsf cat asdfadsf dog
asfdadsfads dog asdfasdfadsf cat`
var substitution = "\1 \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}