$re = '/^\d+(?:\.\d+){2}$/';
$str = '11111111.11111111.1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);