use strict;
my $str = 'This is a test of the regular expression. Below is an equation with a label on the same line as begin and an equation on a new line.
\\begin{align}\\label{eq:some_label}
E = m * c^2
\\end{align}
Below is an equation
\\begin{equation}
P_k(t) = K (T_2(t) - T_o(t))
\\end{equation}
Below is both and align and equation with starred variants:
\\begin{align*}
E = m * c^2
\\end{align*}
\\begin{equation*}
E = m * c^2
\\end{align*}
And on one line:
\\begin{equation*}E = m * c^2\\end{align*}
And another environment
\\begin{figure}
...
\\end{figure}';
my $regex = qr/\\begin{(align|equation)\*?}(?P<eq>(.)+?)\\end{(align|equation)\*?}/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}