using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((^|\S+)Nennbetrag(\S+|$))|((^|\S+)Nennbetrag)|(Nennbetrag(\S+|$))";
string input = @"Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetrag
Nennbetragaaaa
aaaaNennbetrag
aaaaNennbetragaaaa
Nennbetrag a
a Nennbetrag
a Nennbetrag a
Nennbetra
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}