import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((^|\\S+)Nennbetrag(\\S+|$))|((^|\\S+)Nennbetrag)|(Nennbetrag(\\S+|$))";
final String string = "Nennbetrag\n"
+ "Nennbetrag \n"
+ " Nennbetrag\n"
+ " Nennbetrag \n"
+ "Nennbetrag \n"
+ " Nennbetrag\n"
+ " Nennbetrag \n"
+ "Nennbetragaaaa\n"
+ "aaaaNennbetrag\n"
+ "aaaaNennbetragaaaa\n"
+ "Nennbetrag a \n"
+ " a Nennbetrag\n"
+ " a Nennbetrag a \n"
+ "Nennbetra\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}