$re = '/\b(?:\d{1,2}[- \/]\s?){2}(?:\d{4}|\d{2})\b/';
$str = '11/11/1111
11-11-1111
11 11 1111
11- 11- 1111
11 11 1111
11-11 1111
23- 10-17
9 06- 17
1$0%11
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);