// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:\d{1,2}[- \/]\s?){2}(?:\d{4}|\d{2})\b").unwrap();
let string = "11/11/1111
11-11-1111
11 11 1111
11- 11- 1111
11 11 1111
11-11 1111
23- 10-17
9 06- 17
1$0%11
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}