import Foundation
let pattern = #"\b(?:\d{1,2}[- \/]\s?){2}(?:\d{4}|\d{2})\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
11/11/1111
11-11-1111
11 11 1111
11- 11- 1111
11 11 1111
11-11 1111
23- 10-17
9 06- 17
1$0%11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)