# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?-(.+?)-?_.*/$1/gm;t' <<< "veiculos-sao-paulo-__4--6--.html
veiculos-parana__4--6--.html
veiculos-rio-de-janeiro-__4--6--.html"