use strict;
my $str = 'veiculos-sao-paulo-__4--6--.html
veiculos-parana__4--6--.html
veiculos-rio-de-janeiro-__4--6--.html';
my $regex = qr/.*?-(.+?)-?_.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";