re = /.*?-(.+?)-?_.*/m
str = 'veiculos-sao-paulo-__4--6--.html
veiculos-parana__4--6--.html
veiculos-rio-de-janeiro-__4--6--.html'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result