const regex = /(?<![\p{Letter}\d_])test(?![\p{Letter}\d_])/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\p{Letter}\\d_])test(?![\\p{Letter}\\d_])', 'gu')
const str = `teststring
testö
testœ
test1
test_
test.
test,
test/
test
stringtest
ötest
œtest
1test
_test
.test
,test
/test
test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}