use strict;
my $str = 'teststring
testö
testœ
test1
test_
test.
test,
test/
test
stringtest
ötest
œtest
1test
_test
.test
,test
/test
test
';
my $regex = qr/(?<![\p{Letter}\d_])test(?![\p{Letter}\d_])/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}