# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\s)@aaa\|sss\b/55/gs;t' <<< "Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5"