using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0?[1-9]|1[012])\/(0?[1-9]|[12][0-9]|3[01])\/\d{2} ([0-1]?\d|2[0-3])(?::([0-5]?\d)) (A|P)M";
string input = @"4/3/19 5:27 AM
12/31/19 11:59 PM";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}