re = /(?<number1>\d{8})_(?<number2>\d{4})/m
str = 'c:\\Folder\\Nr_11111111_2222.pdf
c:\\Folder\\Nr_11111111_2222_1.pdf
c:\\Folder\\Nr_33333333_2222.pdf
c:\\Folder\\Nr_33333333_2222.pdf
c:\\Folder\\Nr_44444444_2222.pdf
c:\\Folder\\Nr_44444444_2222.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end