package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))|(([0-9]{2,3}[:-]){5}([0-9]{2,3})))`)
var str = `123-201-12-01-125-212`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}