re = /((([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))|(([0-9]{2,3}[:-]){5}([0-9]{2,3})))/m
str = '123-201-12-01-125-212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end