# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^(?<forename>.+?)\s(?<surname>\w+)\nBirth\n(?:(?<birth_day>(\d{1,2}|unknown))\s(?<birth_month>\w{3})\s(?<birth_year>\d{4})|\bunknown\b)\n(?<birth_location>.+?)\nDeath\n(?:(?<death_day>(\d{1,2}|unknown))\s(?<death_month>\w{3})\s(?<death_year>\d{4})(?:\s*\(aged\s*(?<age>\d+)\))?|unknown)\n(?<death_location>.+?)\nBurial\n(?<cemetery_name>.+?)\n(?<cemetery_location>.+?)\n(?:Show MapGPS-Latitude:\s*(?<latitude>-?\d+\.\d+),\s*Longitude:\s*(?<longitude>-?\d+\.\d+))?\n?(?:Plot\n(?<plot>.+?)\n?)?Memorial ID\n(?<memorial_id>\d+)\n")
test_str = ("Frederick Clarke\n"
"Birth\n"
"6 Feb 1871\n"
"Death\n"
"7 Nov 1952 (aged 81)\n"
"Sheffield\n"
"Burial\n"
"Crookes Cemetery\n"
"Sheffield, Metropolitan Borough of Sheffield, South Yorkshire, England\n"
"Show MapGPS-Latitude: 53.384024, Longitude: -1.515043\n"
"Plot\n"
"MM 7848\n"
"Memorial ID\n"
"237065233")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.