# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(\(\(?([^}]*?)\)\)\)"
test_str = ("((Short Title (in Navigation & Breadcrumb))) Pflanzen & Samen\n"
"((Post-Text)) Hast du unser Osterschoggi-Sortiment schon probiert? ((Schleckmaul))\n"
"[Ceci est un ((non visible)) (test)]\n"
"[[Ceci est un ((non visible)) (test)]]\n"
"Ceci est un [[visible ((non visible))]] (test)\n"
"Ceci est un ((non visible [non visible])) (test)\n"
"((Headline))\n"
"((non visible)) \n"
"Ceci doit être traduit\n"
"((Sternchentext))\n"
"*Mit Cashback Fr. 39.90, Rückvergütung (Überweisung) einlösbar unter canon.ch/summer, gültig von 15.2. bis 15.5.2021 ((maximal 140 Zeichen inkl. Leerzeichen))\n"
"Lieferung per Paketkurier (Direktlieferung (normal))\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.