using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(srn\.firsttname)( like '%?\w+%?' and )(.*?)(srn\.lastname)(.*)";
string substitution = @"$1$5$3$2$6";
string input = @"Results where srn.firsttname like 'Chicken%' and coalesce(sri.DocumentType_id,0) not in (71, 72, 70, 69) and having srn.lastname like 'Alfredo%'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}