// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*?)(srn\.firsttname)( like '%?\w+%?' and )(.*?)(srn\.lastname)(.*)").unwrap();
let string = "Results where srn.firsttname like 'Chicken%' and coalesce(sri.DocumentType_id,0) not in (71, 72, 70, 69) and having srn.lastname like 'Alfredo%'";
let substitution = "$1$5$3$2$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}