$re = '/^(\S+),?\s.[^@]*(@\r?\n\1.*|\r?\n\1.*@)$/m';
$str = 'увацуа каакак акака акакуа
æввонгхуар дармоед, тунеядец.
æввонгхуар дармоед, тунеядец
æваст т.ж. æвваст 1) вдруг, внезапно, быстро, нæр неожиданно раздавшийся крик;
æваст тж. æвваст енно æваст гъæр − неожиданно раздавшмовольно, без ведома@
æвастæй самовольно, без спроса; произ¬вольно.
æвастæй самовольно, без спроса; произвольно@
æвастгъæр гром, междометие.æввонгхуар дармоед, тунеядец.
æввонгхуар дармоед, тунеядец';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);