using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[\w\s-+.])\s*[-+.'\w]+@[-.\w]+\.[-.\w]+\s*$";
string input = @"dfdfd@bcvb.com,
dfdfd@bcvb.com`
test@test.com
'd@dfgdfg.com
`d@dfgdfg.com
ab12@bc.co
space@test.check ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}