re = /(.*\/)([01])(\w{32})[\/](.*)$/m
str = '/wp-json/fy/e2/03f076b7094cd0c85c0bead50eb232c0c/settings'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end