// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*\/)([01])(\w{32})[\/](.*)$").unwrap();
let string = "/wp-json/fy/e2/03f076b7094cd0c85c0bead50eb232c0c/settings";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}