#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\.{2,}|(?<=[^\s.]))$"
Local $sString = "python...is...fun..." & @CRLF & _
"python...is...fun" & @CRLF & _
"python...is...fun??" & @CRLF & _
"" & @CRLF & _
"test " & @CRLF & _
""
Local $sSubst = "."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)