using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\.{2,}|(?<=[^\s.]))$";
string substitution = @".";
string input = @"python...is...fun...
python...is...fun
python...is...fun??
test
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}