$re = '/(?:\.{2,}|(?<=[^\s.]))$/m';
$str = 'python...is...fun...
python...is...fun
python...is...fun??
test
';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;