re = /(?:\.{2,}|(?<=[^\s.]))$/m
str = 'python...is...fun...
python...is...fun
python...is...fun??
test
'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result