const regex = new RegExp('^(([а-яa-zё0-9]){2})\\.((?2){2})\\.((?2){3})$', 'ui')
const str = `d1.df.dfd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}