import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(\\d+)\\s+(\\S+(?: \\S+)*)\\s+(\\S+(?: \\S+)*)\\s+(\\S+(?: \\S+)*)\\s+(\\S+(?: \\S+)*)\\s+(\\S+(?: \\S+)*)$";
final String string = " 8 SIRIO S.P.A. BOMBARDIER INC. BD-100-1A10 I-FORZ STANDARD\n\n"
+ " 9 ESERCENTE PRIVATO PIAGGIO AERO INDUSTRIES S.P.A. P.180 AVANTI II I-FXRJ SPECIALE/STANDARD\n\n"
+ "10 MIGNINI & PETRINI S.P.A. ROBINSON HELICOPTER COMPANY R44 II I-HIKE SPECIALE/STANDARD\n\n"
+ "11 MIGNINI & PETRINI S.P.A. ROBINSON HELICOPTER COMPANY R44 II I-HIKE STANDARD\n\n"
+ "12 BLUE PANORAMA AIRLINES S.P.A. THE BOEING COMPANY 737-86N I-LCFC STANDARD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}