// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([123456789]{9})([ABCD]{1,4})([0]{1,5})([0-9]{1,5})([D]*)$").unwrap();
let string = "123456789ABCD00001DDD";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}