import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?s).*Subject:(?<identificationValue>ST[0-9]*)\\.\\d*\\.\\d*\\.(?<identifier>[0-9]*).*Text: (?<remark>.*)Code:.*$";
final String string = "From:stoerungen@fe-trading.at\n"
+ "Subject:ST412.3.3.28 [RCT/28]: Kartenleserfehler, bitte pruefen!\n"
+ "Send date:Mon May 08 13:28:51 CET 2017\n"
+ "Content type:text/plain; charset=\"iso-8859-1\"\n\n"
+ "System: RCT/FAULT (08.05.2017 13:28:51)\n"
+ "Station: ST412, 4846 Redlham, Gewerbepark Ost 27\n"
+ "Text: Kartenleserfehler, bitte pruefen!\n"
+ "Gruppe: 3\n"
+ "Device: 3\n"
+ "Code: 28";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}