^start of string
(?s)applies the following effective flags to the remainder of the pattern: gs s modifier: single line. Allows a dot to match line terminators
.*any character, repeated any number of times
Subject:the literal text Subject: (case sensitive) Group identificationValue(?<identificationValue>ST[0-9]*) STthe literal text ST (case sensitive) *matches any number of characters from the set below:
0-9one character from 0 (4810) to 9 (5710)
\.the literal . (4610 / 568 / 2E16)
\d*a digit, repeated any number of times
\.the literal . (4610 / 568 / 2E16)
\d*a digit, repeated any number of times
\.the literal . (4610 / 568 / 2E16)
Group identifier(?<identifier>[0-9]*) *matches any number of characters from the set below:
0-9one character from 0 (4810) to 9 (5710)
.*any character, repeated any number of times
Text: the literal text Text: (case sensitive) Group remark(?<remark>.*) .*any character, repeated any number of times
Code:the literal text Code: (case sensitive) .*any character, repeated any number of times
$end of string, or before its final line terminator
g modifier: global. Finds all matches instead of stopping after the first