import re
regex = re.compile(r"^(?s).*Subject:(?<identificationValue>ST[0-9]*)\.\d*\.\d*\.(?<identifier>[0-9]*).*Text: (?<remark>.*)Code:.*$")
test_str = ("From:stoerungen@fe-trading.at\n"
"Subject:ST412.3.3.28 [RCT/28]: Kartenleserfehler, bitte pruefen!\n"
"Send date:Mon May 08 13:28:51 CET 2017\n"
"Content type:text/plain; charset=\"iso-8859-1\"\n\n"
"System: RCT/FAULT (08.05.2017 13:28:51)\n"
"Station: ST412, 4846 Redlham, Gewerbepark Ost 27\n"
"Text: Kartenleserfehler, bitte pruefen!\n"
"Gruppe: 3\n"
"Device: 3\n"
"Code: 28")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")